Note: The other languages of the website are Google-translated. Back to English
Accedi  \/ 
x
or
x
Registrati  \/ 
x

or

Funzione EXCEL COUNTIF: conta le celle che non sono vuote, maggiori/minori di o contengono un valore specifico

Quando si lavora su un foglio di lavoro Excel, contare il numero di celle, ad esempio contare celle vuote o non vuote, celle maggiori o minori di un determinato valore o celle che contengono un testo specifico possono essere alcune attività comuni per la maggior parte delle noi. Per gestire questi calcoli, la funzione CONTA in Excel potrebbe farti un favore.

Sintassi della funzione CONTA.SE in Excel

Funzione CONTA.SE per celle vuote o non vuote

Funzione CONTA.SE per celle inferiori, maggiori o uguali a un valore specifico

La funzione CONTA.SE per le celle contiene un valore specifico


Sintassi della funzione CONTA.SE in Excel

Come una delle funzioni statistiche in Excel, CONTA.SE conta le celle che soddisfano determinati criteri in un intervallo specificato. La sintassi della funzione CONTA.SE è:

=COUNTIF(range, criteria)

La sintassi contiene due argomenti: gamma , che collaborano con noi, attingono direttamente dalla storia e dalla tradizione veneziana criteri:

  • gamma: si riferisce all'intervallo di celle che si desidera contare.
  • criteri: si riferisce alla condizione che si desidera utilizzare per contare le celle. Ad esempio, puoi utilizzare ">=80" come criterio per cercare le celle con valori maggiori o uguali a 80 nell'intervallo selezionato.

Per applicare la funzione in Excel, dovresti digitare = CONTA.SE (intervallo, criteri) in una cella di destinazione. Per esempio, =CONTA.SE(A1:B8;">=80").

La funzione CONTA.SE restituisce un valore numerico: il numero delle celle che si desidera contare.

Ora che abbiamo una comprensione più chiara della funzione CONTA.SE, passiamo ad alcuni esempi reali.


Funzione CONTA.SE per celle vuote o non vuote

Ad esempio, ho un elenco di celle che contiene diversi tipi di dati, come testo, valori booleani (VERO e FALSO), numeri, date ed errori. Esiste una formula COUNTIF universale per contare solo le celle vuote o non vuote, indipendentemente dai tipi di dati presenti nell'intervallo specificato?

countif vuoto meno 1

Conta le celle vuote con la funzione CONTA.SE

Ora, lascia che ti presenti la formula CONTA.SE. Con la formula, indipendentemente da quanti tipi di dati esistono nell'intervallo, ti dirà il numero esatto e corretto delle celle vuote:

=COUNTIF(range,"")
Note: Non c'è testo tra virgolette, il che significa che le celle che vuoi contare sono vuote.

Per utilizzare la funzione CONTA.SE per contare le celle vuote, digita la formula =CONTA.SE(A1:A9,"") in una cella di destinazione, quindi premere ENTRA:

countif vuoto meno 2 >>> countif vuoto meno 3

In Excel c'è anche una funzione chiamata COUNTBLANK, che restituisce il numero di celle vuote in un intervallo specificato. La sintassi è = COUNTBLANK (range). Per l'esempio sopra, puoi usare la formula: =CONTA.VUOTE(A1:A9).


Conta le celle non vuote con la funzione CONTA.SE

Per contare le celle che non sono vuote, qui, lascia che ti mostri la formula:

=COUNTIF(range,"<>")
Nota: <> in Excel significa non uguale a. Quindi, la formula sopra conta tutte le celle che non sono uguali a vuote, o possiamo dire, non sono vuote.

Per utilizzare la funzione CONTA.SE per contare le celle che non sono vuote, digita la formula =CONTA.SE(A1:A9;"<>") in una cella di destinazione, quindi premere ENTRA:

countif vuoto meno 4 >>> countif vuoto meno 5

In Excel c'è anche una funzione chiamata COUNTA, che restituisce il numero di celle contenenti qualsiasi valore in un intervallo specificato. La sintassi è =CONTA.VALORI(intervallo). Per l'esempio sopra, puoi usare la formula: = CONTA.VALORI (A1: A9).

Tuttavia, se desideri contare solo le celle con solo testo ed escludere i valori booleani (VERO e FALSO), numeri, date o errori, utilizza la formula seguente:

=COUNTIF(A1:A9,"*")
Note: A single asterisk (*) matches only the value in a text form.

countif vuoto meno 6 >>> countif vuoto meno 7

Conta le celle non vuote con due clic

Se haive Kutools for Excel installato nel tuo excel, con il suo Seleziona Celle non vuote funzione, puoi selezionare tutte le celle non vuote contemporaneamente e ottenere il numero di cui hai bisogno.

1. Puoi andare al Kutools scheda in Excel, trova Selezionae fare clic Seleziona Celle non vuote nell'elenco a discesa. Vedi screenshot:

countif vuoto meno 8

2. Tutte le celle non vuote verranno selezionate e verrà visualizzata una finestra di messaggio per indicare il numero di celle non vuote come mostrato nell'immagine sottostante:

countif vuoto meno 9

Fare clic per scaricare Kutools per Excel per una prova gratuita di 30 giorni.


Funzione CONTA.SE per celle inferiori, maggiori o uguali a un valore specifico

Qui abbiamo elencato due metodi principali per contare le celle con valori inferiori, maggiori, uguali o non uguali a un valore specifico in Excel.

CONTA.SE minore di, maggiore di, uguale o diverso da con le formule

Per utilizzare una formula per contare le celle con valori inferiori, maggiori, uguali o non uguali a un valore specifico, dovresti fare buon uso di Operatori di confronto (<, >, =, ).

Note: Il metodo può essere utilizzato anche per contare le celle con date precedenti (minori di <), dopo (maggiori di >) o uguali a (=) la data specificata.

Ora, diamo un'occhiata ad alcuni esempi reali secondo la tabella seguente:

countif vuoto meno 10

Per contare il numero di studenti il ​​cui punteggio totale è oltre (>) 140, usa la formula:
=CONTA.SE(E2:E8;">140") >>> Il risultato è 5
Per contare il numero di studenti il ​​cui punteggio in matematica è inferiore a (<) il punteggio di Coco (il valore nella cella D3), usa la formula:
=CONTA.SE(D2:D8;"<"&D3) >>> Il risultato è 2
Nota: per utilizzare un riferimento di cella nella funzione CONTA.SE con operatori di confronto, dovrai inserire gli operatori tra virgolette e aggiungere una e commerciale (&) prima del riferimento di cella.
Per contare il numero di studenti il ​​cui punteggio di inglese è maggiore o uguale a (≥) il punteggio di Eddie (il valore nella cella C4), usa la formula:
=COUNTIF(C2:C8,">="&C4)-1 >>> The result is 5
Nota: il motivo per sottrarre 1 è che i criteri DO2: DO8,">="&DO4 chiedi a CONTA.SE di contare tutte le celle corrispondenti inclusa quella con il punteggio inglese di Eddie, quindi dobbiamo sottrarlo dalla formula. Se hai bisogno di contare Eddie, elimina "-1” dalla formula.
Per contare il numero di studenti che provengono da (=) India, usa la formula:
=CONTA.SE(B2:B8;"India") OR =CONTA.SE(B2:B8,B2) >>> Il risultato è 3
Nota: il valore nel riferimento di cella B2 è l'India, quindi "India" , che collaborano con noi, attingono direttamente dalla storia e dalla tradizione veneziana B2 sono entrambi ok che funzionano come criteri qui. Nella funzione CONTA.SE, i criteri sono Non sensibile a maiuscole e minuscole. Quindi, la stringa "India" e "INDIA" non farà alcuna differenza per il risultato della formula.
Per contare il numero di studenti che non provengono da (≠) India, usa la formula:
=CONTA.SE(B2:B8;"<>India") OR =CONTA.SE(B2:B8,"<>"&B2) >>> Il risultato è 4

La funzione CONTA.SE funziona solo quando c'è una condizione, per la situazione di più condizioni, dovresti usare la funzione CONTA.SE. Ad esempio, per contare il numero di studenti il ​​cui punteggio in inglese è compreso tra 60 e 90 (>60, <90), utilizzare la formula: =COUNTIFS(B2:B8,">60",B2:B8,"<90").
Clicca per saperne di più sulla funzione CONTA.PI.SE...


CONTA.SE minore di, maggiore di, uguale o diverso da con pochi clic

Per contare le celle con valori minori, maggiori, uguali o non uguali a un valore specifico in un modo più conveniente, puoi applicare il Seleziona celle specifiche funzione dif Kutools for Excel.

Dopo aver installato Kutools per Excel, eseguire i seguenti passaggi:

1. Si prega di trovare il Kutools scheda, quindi vai a Selezionae fare clic Seleziona celle specifiche nell'elenco a discesa.

countif vuoto meno 11

2. Ora vedrai una finestra pop-up, per favore fai come segue:

countif vuoto meno 11

Di seguito è riportato un esempio per contare il numero di studenti il ​​cui punteggio in matematica è inferiore a (<) il punteggio di Coco con Kutools.

countif vuoto meno 11

Nota: il programma restituirà il risultato del conteggio e selezionerà le celle che soddisfano i tuoi criteri. Puoi copiarli se ne hai bisogno.

Fare clic per scaricare Kutools per Excel per una prova gratuita di 30 giorni.


La funzione CONTA.SE per le celle contiene un valore specifico

Per utilizzare CONTA.SE per contare le celle che contengono un valore specifico (ad esempio le celle con una lettera Y), o anche per contare le celle con un valore specifico in una posizione specifica (ad esempio le celle iniziano con una lettera Y), noi devono conoscere i caratteri jolly.

Ci sono tre caratteri jolly - asterisco (*), domanda marchio (?), E tilde (~) disponibile in Excel per la funzione CONTA.SE:

· XNUMX€ asterisco (*) - Corrisponde a qualsiasi numero di caratteri. Ad esempio, *ice potrebbe significare carino, servizio, ghiaccio, @#$ice, ecc.
· XNUMX€ Punto interrogativo (?) - Corrisponde a qualsiasi carattere. Ad esempio, mo?? potrebbe significare di più, luna, mo&%, moaa, ecc.
· XNUMX€ tilde (~) - Corrisponde al carattere jolly effettivo. Ad esempio, ~* significa un asterisco letterale, ~~ significa una tilde letterale.

Nota: i valori booleani (VERO e FALSO), i numeri, le date e gli errori non vengono conteggiati come caratteri. Quindi, se ci sono elementi sopra nell'intervallo di celle che hai selezionato, dovrai convertirli in testo.

Maggiori informazioni:
Come modificare o convertire il numero in testo in Excel?
Come convertire la data in stringa numerica o in formato testo in Excel?
Come sostituire # errori di formula con 0, vuoto o determinato testo in Excel?
Come convertire booleano vero/falso in numero (1/0) o testo in Excel?


Conta le celle contenenti parole o caratteri specifici con la funzione CONTA.SE

Poiché conosciamo già i caratteri jolly, è ora che impariamo come utilizzare una formula CONTA.SE per contare le celle che contengono uno o più caratteri o parole specifici. Vediamo gli esempi di seguito:

countif vuoto meno 1

Per contare il numero di ragazzi in classe, usa la formula:
=CONTA.SE(B2:B9,"MASCHIO") >>> Il risultato è 5
Per contare il numero di nomi che contiene i caratteri "jeff" (il valore nella cella A6), usa la formula:
=CONTA.SE(A2:A9;"*jeff*") OR = CONTA.SE (A2: A9, "*" e A6 & "*") >>> Il risultato è 2
Per contare il numero di nomi che contengono la lettera "e", utilizzare la formula:
=COUNTIF(A2:A9,"*e*") >>> The result is 5
Per contare il numero di nomi che non contengono la lettera "e", usa la formula:
=CONTA.SE(A2:A9;"<>*e*") >>> Il risultato è 3
Per contare il numero di nomi che iniziano con la lettera "e", utilizzare la formula:
=CONTA.SE(A2:A9,"e*") >>> Il risultato è 2
Per contare il numero di nomi che terminano con la lettera "e", utilizzare la formula:
=CONTA.SE(A2:A9;"*e") >>> Il risultato è 1
Per contare il numero di nomi con la lettera "m" come terzo carattere, utilizzare la formula:
=CONTA.SE(A2:A9;"??m*") >>> Il risultato è 2

Conta le celle contenenti parole o caratteri specifici con pochi clic

Con our Componente aggiuntivo Excel insttutto, si prega di fare come segue:

1. Vai alla Kutools scheda, trova Selezionae fare clic Seleziona celle specifiche nell'elenco a discesa.

countif vuoto meno 1

2. Nel Seleziona celle specifiche finestra di dialogo, selezionare l'intervallo di celle che si desidera contare, quindi fare clic su Cella sotto il Tipo di selezione, scegli una condizione nell'elenco a discesa del Tipo specifico in base alle tue esigenze.

countif vuoto meno 1

Ecco, ti faccio due esempi di utilizzo Kutools a count le celle che contengono le parole oi caratteri specifici.

• Per contare il numero di ragazzi in classe, fare clic su Equivale nell'elenco a discesa e digitare Uomo nella casella di input a destra, oppure puoi selezionare una cella con il valore "Maschio" nel foglio di lavoro facendo clic su countif vuoto meno 1pulsante.

countif vuoto meno 1

Il programma restituirà il risultato del conteggio e selezionerà le celle che soddisfano i tuoi criteri. Puoi copiarli se ne hai bisogno.

• Per contare il numero di nomi che contengono i caratteri "jeff", fare clic su contiene nell'elenco a discesa e digitare jeffoppure puoi selezionare la cella A6 nel foglio di lavoro facendo clic su countif vuoto meno 1pulsante.

countif vuoto meno 1

Il programma restituirà il risultato del conteggio e selezionerà le celle che soddisfano i tuoi criteri. Puoi copiarli se ne hai bisogno.



  • Bar Super Formula (modifica facilmente più righe di testo e formula); Layout di lettura (leggi e modifica facilmente un gran numero di celle); Incolla su intervallo filtrato...
  • Unisci celle / righe / colonne e conservazione dei dati; Contenuto delle celle divise; Combina righe duplicate e somma / media... Impedisci celle duplicate; Confronta intervalli...
  • Seleziona Duplica o Unico Righe; Seleziona Righe vuote (tutte le celle sono vuote); Super Find e Fuzzy Find in molte cartelle di lavoro; Selezione casuale ...
  • Copia esatta Più celle senza modificare il riferimento della formula; Riferimenti di creazione automatica a più fogli; Inserisci punti elenco, Caselle di controllo e altro ...
  • Formule preferite e di inserimento rapido, Intervalli, grafici e immagini; Crittografa celle con password; Crea mailing list e invia email ...
  • Estrai testo, Aggiungi testo, Rimuovi per posizione, Rimuovi spazio; Creare e stampare totali parziali di paging; Converti contenuto e commenti tra celle...
  • Super filtro (salva e applica schemi di filtri ad altri fogli); Ordinamento avanzato per mese / settimana / giorno, frequenza e altro; Filtro speciale in grassetto, corsivo ...
  • Combina cartelle di lavoro e fogli di lavoro; Unisci tabelle in base a colonne chiave; Suddividi i dati in più fogli; Conversione in batch xls, xlsx e PDF...
  • Raggruppamento tabelle pivot per numero della settimana, giorno della settimana e altro ... Mostra celle sbloccate e bloccate da diversi colori; Evidenzia le celle che hanno formula / nome...
scheda kte 201905
  • Abilita la modifica e la lettura a schede in Word, Excel, PowerPoint, Publisher, Access, Visio e Project.
  • Apri e crea più documenti in nuove schede della stessa finestra, piuttosto che in nuove finestre.
  • Aumenta la produttività del 50% e riduce ogni giorno centinaia di clic del mouse!
fondo officetab
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.

Be the first to comment.