Note: The other languages of the website are Google-translated. Back to English

Conta il numero di celle che contengono un numero specifico di caratteri

Se vuoi contare il numero di celle che contengono un certo numero di caratteri (come 5 caratteri) in un intervallo di celle come mostrato nell'immagine sottostante. In Excel, la funzione CONTA.SE può farti un favore. In questo articolo parlerò di come ottenere un numero di celle che contengono esattamente x caratteri o celle che contengono più di un certo numero di caratteri.


Conta il numero di celle che contengono esattamente x caratteri

La funzione CONTA.SE può aiutarti a ottenere il numero di celle che contiene un numero specifico di caratteri, la sintassi generica è:

=COUNTIF(range,"?????")
=CONTA.SE(intervallo,RIPETI(“?”,X))
  • range: l'intervallo di celle che si desidera contare;
  • ?: indica un carattere jolly che corrisponde a qualsiasi singolo carattere;
  • X: il numero di caratteri su cui contare.

1. Inserisci o copia una delle seguenti formule in una cella vuota per generare il risultato:

=COUNTIF(A2:A12,"?????")
=CONTA.SE(A2:A13,RIPETI("?",5))

Note:: Nella prima formula, ????? indica cinque caratteri qualsiasi su cui si desidera contare in base; Nella seconda formula, RIPETI(“?”,5) restituirà una stringa di testo composta esattamente da 5 punti interrogativi. In questo esempio REPT("?",5) restituisce "?????".

2. E poi, premi Entra tasto per ottenere il risultato che ti serve, vedi screenshot:


Conta il numero di celle con una lunghezza del testo maggiore di x caratteri

Se vuoi ottenere il numero di celle in cui la lunghezza del testo è maggiore di 15 caratteri, puoi applicare le funzioni SUMPRODUCT, LEN e N insieme, la sintassi generica è:

=SOMMA.PRODOTTO(N(LUNGHEZZA(intervallo)>X))
  • range: l'intervallo di celle che si desidera contare;
  • X: il numero di caratteri su cui contare.

1. Inserisci o copia la formula seguente in una cella vuota:

=SUMPRODUCT(N(LEN(A2:A10)>15))

2. Quindi premere entrare chiave per ottenere il risultato in una volta, vedere screenshot:


Spiegazione della formula:
  • LUNGHEZZA(A2:A10): Questa funzione LEN calcola la lunghezza per ogni cella dell'intervallo selezionato e restituisce l'elenco di array come questo: {17;10;12;22;19;10;14;21;9}.
  • LUNGHEZZA(A2:A10)>15: Questa parte confronta la lunghezza del testo di ogni cella con il numero specifico 15, se maggiore di 15, visualizza VERO, altrimenti restituisce FALSO. Otterrà il risultato come questo: {VERO;FALSO;FALSO;VERO;VERO;FALSO;FALSO;VERO;FALSO}.
  • N(LEN(A2:A10)>15): Questa funzione N viene utilizzata per convertire VERO e FALSO rispettivamente in 1 e 0, in questo modo: {1;0;0;1;1;0;0;1;0}
  • SUMPRODUCT(N(LEN(A2:A10)>15))=SUMPRODUCT({1;0;0;1;1;0;0;1;0}): Alla fine, questa funzione SUMPRODUCT sommerà tutti i numeri nell'array, quindi otterrai il risultato: 4.

Funzione relativa utilizzata:

  • COUNTIF:
  • La funzione CONTA.SE è una funzione statistica in Excel che viene utilizzata per contare il numero di celle che soddisfano un criterio.
  • MATR.SOMMA.PRODOTTO:
  • La funzione SUMPRODUCT può essere utilizzata per moltiplicare due o più colonne o matrici insieme e quindi ottenere la somma dei prodotti.
  • LEN:
  • La funzione LEN restituisce il numero di caratteri in una stringa di testo.
  • N:
  • La funzione N converte un valore in un numero.

Altri articoli:

  • Contare il numero di celle non uguale a molti valori in Excel
  • In Excel, puoi facilmente ottenere il numero di celle non uguale a un valore specifico utilizzando la funzione CONTA.SE, ma hai mai provato a contare le celle che non sono uguali a molti valori? Ad esempio, voglio ottenere il numero totale dei prodotti nella colonna A ma escludere gli articoli specifici in C4: C6 come mostrato nell'immagine sottostante. In questo articolo, introdurrò alcune formule per risolvere questo lavoro in Excel.
  • Conta il numero di celle che contengono numeri pari o dispari
  • Come tutti sappiamo, i numeri dispari hanno un resto di 1 quando divisi per 2 e i numeri pari hanno un resto di 0 quando divisi per 2. In questo tutorial parlerò di come ottenere il numero di celle che contengono pari o dispari numeri in Excel.
  • Conteggio numero di celle contenenti valori numerici o non numerici
  • Se hai un intervallo di dati che contiene sia valori numerici che non numerici, e ora, potresti voler contare il numero di celle numeriche o non numeriche come mostrato nell'immagine sottostante. In questo articolo parlerò di alcune formule per risolvere questa attività in Excel.

I migliori strumenti per la produttività in ufficio

Kutools per Excel: ti aiuta a distinguerti dalla folla

Vorresti completare il tuo lavoro quotidiano in modo rapido e perfetto? Kutools per Excel offre 300 potenti funzionalità avanzate (Combina cartelle di lavoro, somma per colore, contenuto di celle divise, converti data e così via ...) e risparmia l'80% di tempo per te.

  • Progettato per 1500 scenari di lavoro, ti aiuta a risolvere l'80% dei problemi di Excel.
  • Riduci migliaia di clic della tastiera e del mouse ogni giorno, allevia i tuoi occhi e le tue mani stanche.
  • Diventa un esperto di Excel in 3 minuti. Non è più necessario ricordare formule dolorose e codici VBA.
  • Prova gratuita illimitata di 30 giorni. Garanzia di rimborso di 60 giorni. Aggiornamento gratuito e supporto per 2 anni.
Nastro di Excel (con Kutools per Excel installato)

Scheda Office: abilita la lettura e la modifica a schede in Microsoft Office (incluso Excel)

  • Un secondo per passare da una dozzina di documenti aperti all'altra!
  • Riduci ogni giorno centinaia di clic del mouse, dì addio alla mano del mouse.
  • Aumenta la produttività del 50% durante la visualizzazione e la modifica di più documenti.
  • Porta schede efficienti in Office (incluso Excel), proprio come Chrome, Firefox e il nuovo Internet Explorer.
Screenshot di Excel (con la scheda Office installata)
Commenti (0)
Ancora nessuna valutazione. Puoi essere il primo a votare!
Non ci sono ancora commenti pubblicati qui
Lasciate i vostri commenti
Pubblicazione come ospite
×
Valuta questo post:
0  Personaggi
Posizioni suggerite