Note: The other languages of the website are Google-translated. Back to English

Trova i valori mancanti

Ci sono casi in cui è necessario confrontare due elenchi per verificare se esiste un valore dell'elenco A nell'elenco B in Excel. Ad esempio, si dispone di un elenco di prodotti e si desidera verificare se i prodotti nell'elenco sono presenti nell'elenco dei prodotti fornito dal fornitore. Per svolgere questo compito, qui di seguito abbiamo elencato tre modi, sentiti libero di scegliere quello che ti piace.

trova i valori mancanti 1

Trova i valori mancanti con MATCH, ISNA e IF
Trova i valori mancanti con CERCA.VERT, ISNA e SE
Trova i valori mancanti con CONTA.SE e SE


Trova i valori mancanti con MATCH, ISNA e IF

Per scoprire se tutti i prodotti della tua lista sono presenti nella lista del tuo fornitore come mostrato nella schermata sopra, puoi prima utilizzare la funzione CONFRONTA per recuperare la posizione di un prodotto della tua lista (valore della lista A) nella lista dei fornitori (lista B). CONFRONTA restituirà l'errore #N/A quando un prodotto non viene trovato. Quindi puoi inviare il risultato a ISNA per convertire gli errori #N/A in TRUE, il che significa che mancano quei prodotti. La funzione SE restituirà quindi il risultato che ti aspetti.

Sintassi generica

=IF(ISNA(MATCH("lookup_value",lookup_range,0)),"Missing","Found")

√ Nota: puoi modificare "Mancante", "Trovato" con qualsiasi valore di cui hai bisogno.

  • valore di ricerca: Il valore CONFRONTA utilizzato per recuperare la sua posizione se esiste in intervallo_di ricerca o errore #N/A in caso contrario. Qui si riferisce ai prodotti nella tua lista.
  • ricerca_intervallo: L'intervallo di celle da confrontare con il valore di ricerca. Qui si fa riferimento all'elenco dei prodotti del fornitore.

Per scoprire se tutti i prodotti della tua lista sono presenti nella lista del tuo fornitore, per favore copia o inserisci la formula sotto nella cella H6 e premi Entra per ottenere il risultato:

=SE(VAL.SE(CONFRONTA(30002,$ B $ 6: $ B $ 10,0)),"Mancante","Trovato")

Oppure, usa un riferimento di cella per rendere dinamica la formula:

=SE(VAL.SE(CONFRONTA(G6,$ B $ 6: $ B $ 10,0)),"Mancante","Trovato")

√ Nota: i simboli del dollaro ($) sopra indicano i riferimenti assoluti, il che significa che intervallo_di ricerca nella formula non cambierà quando sposti o copi la formula in altre celle. Tuttavia, non ci sono segni di dollaro aggiunti al valore di ricerca dal momento che vuoi che sia dinamico. Dopo aver inserito la formula, trascina verso il basso il quadratino di riempimento per applicare la formula alle celle sottostanti.

trova i valori mancanti 2

Spiegazione della formula

Qui usiamo la formula seguente come esempio:

=IF(ISNA(MATCH(G8,$B$6:$B$10,0)),"Missing","Found")

  • CONFRONTA(G8,$B$6:$B$10,0): Il match_type 0 forza la funzione CONFRONTA a restituire un valore numerico che indica la posizione della prima corrispondenza di 3004, il valore nella cella G8, nell'array $ B $ 6: $ B $ 10. Tuttavia, in questo caso, MATCH non è riuscito a trovare il valore nell'array di ricerca, quindi restituirà il #N / A errore.
  • ISNA(CONFRONTA(G8,$B$6:$B$10,0)) = ISNA(#N / A): ISNA lavora per scoprire se un valore è un errore "#N/A" o meno. Se sì, la funzione restituirà TURE; Se il valore è diverso dall'errore "#N/A", restituirà FALSE. Quindi, questa formula ISNA tornerà TURE.
  • SE(ISNA(CONFRONTA(G8,$B$6:$B$10,0)),"Mancante","Trovato") = SE(TRUE,"Mancante","Trovato"): La funzione IF restituirà Missing se il confronto effettuato da ISNA e MATCH è TRUE, altrimenti restituirà Found. Quindi, la formula tornerà Mancante.

Trova i valori mancanti con CERCA.VERT, ISNA e SE

Per scoprire se tutti i prodotti della tua lista sono presenti nella lista del tuo fornitore, puoi sostituire la funzione CONFRONTA sopra con CERCA.VERT, poiché funziona come CONFRONTA che restituirà l'errore #N/A se il valore non esiste in un altro elenco, o diciamo che manca.

Sintassi generica

=IF(ISNA(VLOOKUP("lookup_value",lookup_range,1,FALSE)),"Missing","Found")

√ Nota: puoi modificare "Mancante", "Trovato" con qualsiasi valore di cui hai bisogno.

  • valore di ricerca: Il valore CERCA.VERT utilizzato per recuperare la sua posizione se esiste in intervallo_di ricerca o errore #N/A in caso contrario. Qui si riferisce ai prodotti nella tua lista.
  • ricerca_intervallo: L'intervallo di celle da confrontare con il valore di ricerca. Qui si fa riferimento all'elenco dei prodotti del fornitore.

Per sapere se tutti i prodotti della tua lista sono presenti nella lista del tuo fornitore, copia o inserisci la formula sottostante nella cella H6 e premi Entra per ottenere il risultato:

=SE(VAL.SE(CERCA.VERT(30002,$ B $ 6: $ B $ 10,1,FALSE)),"Mancante","Trovato")

Oppure, usa un riferimento di cella per rendere dinamica la formula:

=SE(VAL.SE(CERCA.VERT(G6,$ B $ 6: $ B $ 10,1,FALSE)),"Mancante","Trovato")

√ Nota: i simboli del dollaro ($) sopra indicano i riferimenti assoluti, il che significa che intervallo_di ricerca nella formula non cambierà quando sposti o copi la formula in altre celle. Tuttavia, non ci sono segni di dollaro aggiunti al valore di ricerca dal momento che vuoi che sia dinamico. Dopo aver inserito la formula, trascina verso il basso il quadratino di riempimento per applicare la formula alle celle sottostanti.

trova i valori mancanti 3

Spiegazione della formula

Qui usiamo la formula seguente come esempio:

=IF(ISNA(VLOOKUP(G8,$B$6:$B$10,1,FALSE)),"Missing","Found")

  • CERCA.VERT(G8,$B$6:$B$10,1,FALSO): La gamma_lookup FALSO forza la funzione CERCA.VERT a cercare e restituire il valore che corrisponde esattamente 3004, il valore nella cella G8. Se il lookup_value 3004 esiste nel 1prima colonna dell'array $ B $ 6: $ B $ 10, VLOOKUP restituirà quel valore; In caso contrario, restituirà il valore di errore #N/A. Qui, 3004 non esiste nell'array, quindi il risultato sarebbe #N / A.
  • ISNA(CERCA.VERT(G8,$B$6:$B$10,1,FALSO)) = ISNA(#N / A): ISNA lavora per scoprire se un valore è un errore "#N/A" o meno. Se sì, la funzione restituirà TURE; Se il valore è diverso dall'errore "#N/A", restituirà FALSE. Quindi, questa formula ISNA tornerà TURE.
  • SE(ISNA(CERCA.VERT(G8,$B$6:$B$10,1,FALSO)),"Mancante","Trovato") = SE(TRUE,"Mancante","Trovato"): La funzione SE restituirà Missing se il confronto effettuato da ISNA e VLOOKUP è TRUE, altrimenti restituirà Found. Quindi, la formula tornerà Mancante.

Trova i valori mancanti con CONTA.SE e SE

Per scoprire se tutti i prodotti della tua lista sono presenti nella lista del tuo fornitore, puoi utilizzare una formula più semplice con le funzioni CONTA.SE e SE. La formula sfrutta il fatto che Excel valuterà qualsiasi numero tranne zero (0) come TRUE. Quindi, se un valore esiste in un altro elenco, la funzione CONTA.SE restituirà il conteggio delle sue occorrenze in quell'elenco, quindi SE prenderà il numero come TURE; Se il valore non esiste nell'elenco, la funzione CONTA.SE restituirà 0 e SE lo prenderà come FALSO.

Sintassi generica

=IF(COUNTIF("lookup_range",lookup_value),"Found","Missing")

√ Nota: puoi modificare "Trovato", "Mancante" con qualsiasi valore di cui hai bisogno.

  • ricerca_intervallo: L'intervallo di celle da confrontare con il valore di ricerca. Qui si fa riferimento all'elenco dei prodotti del fornitore.
  • valore di ricerca: Il valore CONTA.SE utilizzato per restituire il numero delle sue occorrenze in intervallo_di ricerca. Qui si riferisce ai prodotti nella tua lista.

Per sapere se tutti i prodotti della tua lista sono presenti nella lista del tuo fornitore, copia o inserisci la formula sottostante nella cella H6 e premi Entra per ottenere il risultato:

=SE(CONTA.SE($ B $ 6: $ B $ 10,30002),"Trovato","Mancante")

Oppure, usa un riferimento di cella per rendere dinamica la formula:

=SE(CONTA.SE($ B $ 6: $ B $ 10,G6),"Trovato","Mancante")

√ Nota: i simboli del dollaro ($) sopra indicano i riferimenti assoluti, il che significa che intervallo_di ricerca nella formula non cambierà quando sposti o copi la formula in altre celle. Tuttavia, non ci sono segni di dollaro aggiunti al valore di ricerca dal momento che vuoi che sia dinamico. Dopo aver inserito la formula, trascina verso il basso il quadratino di riempimento per applicare la formula alle celle sottostanti.

trova i valori mancanti 4

Spiegazione della formula

Qui usiamo la formula seguente come esempio:

=IF(COUNTIF($B$6:$B$10,G8),"Found","Missing")

  • CONTA.SE($B$6:$B$10,G8): La funzione CONTA.SE conta quante volte lo fa 3004, il valore nella cella G8, appare nell'array $ B $ 6: $ B $ 10. Apparentemente, 3004 non esiste nell'array, quindi il risultato sarebbe 0.
  • SE(CONTA.SE($B$6:$B$10,G8),"Trovato","Mancante") = SE(0,"Trovato","Mancante"): La funzione SE valuterà 0 come FALSO. Quindi, la formula tornerà Mancante, il valore da restituire quando il primo aumento restituisce FALSE.

Funzioni correlate

Funzione IF di Excel

La funzione SE è una delle funzioni più semplici e utili nella cartella di lavoro di Excel. Esegue un semplice test logico che dipende dal risultato del confronto e restituisce un valore se il risultato è VERO o un altro valore se il risultato è FALSO.

Funzione Excel MATCH

La funzione CONFRONTA di Excel cerca un valore specifico in un intervallo di celle e restituisce la posizione relativa del valore.

Funzione CERCA.VERT di Excel

La funzione CERCA.VERT di Excel cerca un valore facendo corrispondere la prima colonna di una tabella e restituisce il valore corrispondente da una determinata colonna nella stessa riga.

Funzione CONTA.SE di Excel

La funzione CONTA.SE è una funzione statistica in Excel che viene utilizzata per contare il numero di celle che soddisfano un criterio. Supporta gli operatori logici (<>, =, > e <) ei caratteri jolly (? e *) per la corrispondenza parziale.


Formule correlate

Cerca un valore contenente testo specifico con caratteri jolly

Per trovare la prima corrispondenza che contiene una determinata stringa di testo in un intervallo in Excel, puoi utilizzare una formula INDICE e CONFRONTA con caratteri jolly: l'asterisco (*) e il punto interrogativo (?).

Corrispondenza parziale con CERCA.VERT

Ci sono momenti in cui hai bisogno di Excel per recuperare i dati in base a informazioni parziali. Per risolvere il problema, puoi utilizzare una formula CERCA.VERT insieme ai caratteri jolly: l'asterisco (*) e il punto interrogativo (?).

Corrispondenza approssimativa con INDEX e MATCH

Ci sono momenti in cui abbiamo bisogno di trovare corrispondenze approssimative in Excel per valutare le prestazioni dei dipendenti, valutare i punteggi degli studenti, calcolare l'affrancatura in base al peso, ecc. In questo tutorial, parleremo di come utilizzare le funzioni INDICE e CONFRONTA per recuperare il risultati di cui abbiamo bisogno.

Cerca il valore di corrispondenza più vicino con più criteri

In alcuni casi, potrebbe essere necessario cercare il valore di corrispondenza più vicino o approssimativo in base a più di un criterio. Con la combinazione delle funzioni INDICE, CONFRONTA e SE, puoi farlo rapidamente in Excel.


I migliori strumenti per la produttività in ufficio

Kutools per Excel: ti aiuta a distinguerti dalla folla

Vorresti completare il tuo lavoro quotidiano in modo rapido e perfetto? Kutools per Excel offre 300 potenti funzionalità avanzate (Combina cartelle di lavoro, somma per colore, contenuto di celle divise, converti data e così via ...) e risparmia l'80% di tempo per te.

  • Progettato per 1500 scenari di lavoro, ti aiuta a risolvere l'80% dei problemi di Excel.
  • Riduci migliaia di clic della tastiera e del mouse ogni giorno, allevia i tuoi occhi e le tue mani stanche.
  • Diventa un esperto di Excel in 3 minuti. Non è più necessario ricordare formule dolorose e codici VBA.
  • Prova gratuita illimitata di 30 giorni. Garanzia di rimborso di 60 giorni. Aggiornamento gratuito e supporto per 2 anni.
Nastro di Excel (con Kutools per Excel installato)

Scheda Office: abilita la lettura e la modifica a schede in Microsoft Office (incluso Excel)

  • Un secondo per passare da una dozzina di documenti aperti all'altra!
  • Riduci ogni giorno centinaia di clic del mouse, dì addio alla mano del mouse.
  • Aumenta la produttività del 50% durante la visualizzazione e la modifica di più documenti.
  • Porta schede efficienti in Office (incluso Excel), proprio come Chrome, Firefox e il nuovo Internet Explorer.
Screenshot di Excel (con la scheda Office installata)
Commenti (0)
Ancora nessuna valutazione. Puoi essere il primo a votare!
Non ci sono ancora commenti pubblicati qui
Lasciate i vostri commenti
Pubblicazione come ospite
×
Valuta questo post:
0   Personaggi
Posizioni suggerite