Note: The other languages of the website are Google-translated. Back to English

Cerca un valore contenente testo specifico con caratteri jolly

Per trovare la prima corrispondenza che contiene una determinata stringa di testo in un intervallo in Excel, puoi utilizzare un INDICE e PARTITA formula con caratteri jolly - l'asterisco (*) e il punto interrogativo (?).

valore di ricerca con caratteri jolly 1

Come ottenere il valore della prima corrispondenza con i caratteri jolly?

Prendere il nome contenente la lettera “e” e primo paese che ha "e" come terza lettera dalla tabella come mostrato sopra, dovresti prima sapere come usare i due caratteri jolly: il asterisco (*), che corrisponde a qualsiasi numero di caratteri, e punto interrogativo (?), che corrisponde a un solo carattere. Ad esempio, *ice potrebbe significare riso, servizio, ghiaccio, @#$ice, ecc.; e mo?? potrebbe significare di più, luna, mo&%, umore, ecc. Dopo aver compreso l'uso dei caratteri jolly, possiamo incorporarli in una formula INDICE e CONFRONTA.

Sintassi generica

=INDEX(return_range,MATCH(lookup_value,lookup_array,0))

  • intervallo_ritorno: L'intervallo da cui si desidera che la formula di combinazione restituisca la prima corrispondenza. Qui si riferisce al nome o all'intervallo di paesi.
  • valore di ricerca: Il valore CONFRONTA utilizzato per restituire la posizione del nome o del paese che soddisfa la condizione data nel ricerca_array. Qui si riferisce al nome che contiene la lettera "e" e al paese che ha "e" come terzo carattere.
  • ricerca_array: L'intervallo di celle in cui valore di ricerca È elencato. Qui si riferisce al nome o all'intervallo di paesi.
  • match_type 0: Forza MATCH a trovare il primo valore che è esattamente uguale a valore di ricerca.

Prendere il nome contenente la lettera “e” e primo paese che ha "e" come terzo carattere, per favore copia o inserisci le formule sotto nelle celle F5 e F8 e premi Entra per ottenere i risultati:

Cella F5 = INDICE (B5: B11,INCONTRO("*e*",B5: B11, 0))
Cella F8 = INDICE (C5: C11,INCONTRO("??e*",C5: C11, 0))

valore di ricerca con caratteri jolly 2

Spiegazione della formula

=INDEX(B5:B11,MATCH("*e*",B5:B11,0))

  • CONFRONTA("*e*",B5:B11,0): Il valore di ricerca *e* può corrispondere a qualsiasi parola che contiene la lettera "e", indipendentemente dalla posizione della lettera nella parola. (Si noti che il testo deve essere racchiuso tra virgolette ("") nelle formule di Excel.) match_type 0 chiede alla funzione CONFRONTA di trovare la corrispondenza esatta. La funzione restituirà quindi la posizione del nome contenente la lettera "e" nell'intervallo B5: B11, Che ha 3.
  • INDICE(B5: B11,CONFRONTA("*e*",B5:B11,0)) = INDICE(B5: B11,3): La funzione INDICE restituisce il 3valore rd nell'intervallo dei nomi B5: B11, Che ha Eddie.

=INDEX(C5:C11,MATCH("??e*",C5:C11,0))

  • CONFRONTA("??e*",C5:C11,0): ): il valore di ricerca ??e* può corrispondere a qualsiasi parola che ha "e" come terzo carattere, purché la parola contenga 3 o più caratteri. (Si noti che il testo deve essere racchiuso tra virgolette ("") nelle formule di Excel.) match_type 0 chiede alla funzione CONFRONTA di trovare la corrispondenza esatta. La funzione restituirà quindi la posizione della prima parola che ha "e" come terzo carattere nell'intervallo C5: C11, Che ha 3.
  • INDICE(C5: C11,CONFRONTA("??e*",C5:C11,0)) = INDICE(C5: C11,3): La funzione INDICE restituisce il 3valore rd nell'intervallo di paesi C5: C11, Che ha America.

Funzioni correlate

Funzione Excel INDICE

La funzione INDICE di Excel restituisce il valore visualizzato in base a una determinata posizione da un intervallo o da una matrice.

Funzione Excel MATCH

La funzione CONFRONTA di Excel cerca un valore specifico in un intervallo di celle e restituisce la posizione relativa del valore.


Formule correlate

Corrispondenza esatta con INDEX e MATCH

Se hai bisogno di trovare le informazioni elencate in Excel su uno specifico prodotto, film o persona, ecc., dovresti fare un buon uso della combinazione delle funzioni INDICE e CONFRONTA.

Corrispondenza approssimativa con INDEX e MATCH

Ci sono momenti in cui abbiamo bisogno di trovare corrispondenze approssimative in Excel per valutare le prestazioni dei dipendenti, valutare i punteggi degli studenti, calcolare l'affrancatura in base al peso, ecc. In questo tutorial, parleremo di come utilizzare le funzioni INDICE e CONFRONTA per recuperare il risultati di cui abbiamo bisogno.

Ricerca a sinistra con INDEX e MATCH

Per trovare le informazioni elencate nelle colonne di sinistra in un foglio di calcolo Excel su un determinato elemento che si trova sul lato destro, puoi utilizzare le funzioni INDICE e CONFRONTA. La combinazione delle due funzioni ha il vantaggio di cercare valori in qualsiasi colonna rispetto a un'altra potente funzione di ricerca di Excel, CERCA.VERT.


I migliori strumenti per la produttività in ufficio

Kutools per Excel: ti aiuta a distinguerti dalla folla

Vorresti completare il tuo lavoro quotidiano in modo rapido e perfetto? Kutools per Excel offre 300 potenti funzionalità avanzate (Combina cartelle di lavoro, somma per colore, contenuto di celle divise, converti data e così via ...) e risparmia l'80% di tempo per te.

  • Progettato per 1500 scenari di lavoro, ti aiuta a risolvere l'80% dei problemi di Excel.
  • Riduci migliaia di clic della tastiera e del mouse ogni giorno, allevia i tuoi occhi e le tue mani stanche.
  • Diventa un esperto di Excel in 3 minuti. Non è più necessario ricordare formule dolorose e codici VBA.
  • Prova gratuita illimitata di 30 giorni. Garanzia di rimborso di 60 giorni. Aggiornamento gratuito e supporto per 2 anni.
Nastro di Excel (con Kutools per Excel installato)

Scheda Office: abilita la lettura e la modifica a schede in Microsoft Office (incluso Excel)

  • Un secondo per passare da una dozzina di documenti aperti all'altra!
  • Riduci ogni giorno centinaia di clic del mouse, dì addio alla mano del mouse.
  • Aumenta la produttività del 50% durante la visualizzazione e la modifica di più documenti.
  • Porta schede efficienti in Office (incluso Excel), proprio come Chrome, Firefox e il nuovo Internet Explorer.
Screenshot di Excel (con la scheda Office installata)
Commenti (0)
Ancora nessuna valutazione. Puoi essere il primo a votare!
Non ci sono ancora commenti pubblicati qui
Lasciate i vostri commenti
Pubblicazione come ospite
×
Valuta questo post:
0  Personaggi
Posizioni suggerite